Wednesday, July 16, 2014

Stable Channel Update

The Chrome Team is excited to announce the promotion of Chrome 36 to the Stable channel for Windows, Mac and Linux. Chrome 36.0.1985.125 contains a number of fixes and improvements, including:
  • Rich Notifications Improvements 
  • An Updated Incognito / Guest NTP design
  • The addition of a Browser crash recovery bubble
  • Chrome App Launcher for Linux
  • Lots of under the hood changes for stability and performance

Security Fixes and Rewards

This update includes 26 security fixes. Below, we highlight fixes that were either contributed by external researchers or particularly interesting. Please see the Chromium security page for more information.

[$2000][380885] Medium CVE-2014-3160: Same-Origin-Policy bypass in SVG. Credit to Christian Schneider.

As usual, our ongoing internal security work responsible for a wide range of fixes:
  • [393765] CVE-2014-3162: Various fixes from internal audits, fuzzing and other initiatives.
Many of the above bugs were detected using AddressSanitizer.

Interested in switching release channels? Find out how. If you find a new issue, please let us know by filing a bug.

Matthew Yuan
Google Chrome

Labels:

77 Comments:

Blogger Julian Xhokaxhiu said...

What about the 64-bit version? It was supposed that this release would include it.

11:27 AM, July 16, 2014  
Blogger krtulmay said...

The update is to 36.0.1985.125

12:26 PM, July 16, 2014  
Blogger Rama moorthy said...

Is this update 36.0.1985.125 or 36.0.1985.122
I am seeing 36.0.1985.125 windows binaries here

1:33 PM, July 16, 2014  
Blogger matthewyuan@chromium.org said...

Sorry for the confusion, 122 was a typo, correct version is indeed 125. I've updated the post to reflect this.

1:36 PM, July 16, 2014  
Blogger Anzhel Bozhinov said...

Wow, my installation on Linux receives partial hardware acceleration. Thank you, Google!

1:46 PM, July 16, 2014  
Blogger Rama moorthy said...

This comment has been removed by the author.

2:40 PM, July 16, 2014  
Blogger Adrian n said...

It was about time, Google. This release was waiting to long to be launched.

3:22 PM, July 16, 2014  
Blogger ujud al ikhwan said...

update to 36.0.1985.125 and i used :)

3:24 PM, July 16, 2014  
Blogger Kai Herlemann said...

@Rama moorthy:
Mistakes happens, and that one is a small mistake. Don't overdo.

3:35 PM, July 16, 2014  
Blogger Rafael Hilário said...

Thanks Google for updating the stable channel but still think Google stopped with news on inetrface user many years ago we need an overhaul in designating this excellent web browser does not help only changes under the hood and forget to change the ineterface. We need a good update on the layout because with each passing version Google Chrome continues with the same designe ever.

3:51 PM, July 16, 2014  
Blogger Andrew Schaeffer said...

Why - oh WHY?? do you [development team] insist on breaking high DPI support with every other update? My registry adjustment is no longer helping and I can barely read the top and favorites bars.

7:27 PM, July 16, 2014  
Blogger Rama moorthy said...

@Kai Herlemann
I agree, To err is human .. By the way I am not writing with an insulting intention .. I am just saying ...

10:19 PM, July 16, 2014  
Blogger Ray890 said...

What's been done "under the hood" for 'better performance' in this new release?

11:38 PM, July 16, 2014  
Anonymous Anonymous said...

muchas gracias&congrats!!

now everything is as should be. :)

z

1:53 AM, July 17, 2014  
Blogger Irbidan said...

Can't wait for Stable 64-bit!

3:03 AM, July 17, 2014  
Blogger Timo Poho said...

At least according to peacekeeper.futuremark.com performance has gone down. I used to get 5700+ at best but speed has gone down for a few versions and now i get 4900+. more than 14 percent drop. So much for performance tuning. I am thinking going back to firefox. At least firefox does not spy its users like chrome.

3:11 AM, July 17, 2014  
Blogger Syed Mohammed Ameen said...

Google Chrome updated its version to Chrome 36 with some minor changes and bug fixes

Check Out - http://goo.gl/FnkM1f

4:53 AM, July 17, 2014  
Blogger Zach said...

Why does Chrome use it's own notification method in OS X instead of the native OS X notifications? Are there plans to transition to OS X notifications in the future?

6:05 AM, July 17, 2014  
Blogger Lorenzo said...

Great work!
On linux works better!

9:09 AM, July 17, 2014  
Blogger iron2000 said...

I have Pushbullet running.

For this new update when I reopen Chrome after closing, it will show my last open tabs instead of the NTP. (Settings set to open new tab page on startup)

It wasn't so in the last version.

9:51 AM, July 17, 2014  
Blogger iron2000 said...

Ok, I disabled Pushbullet so Chrome can really close.
Then enabled it back after reopning Chrome.

And the problem is gone.
Perhaps something in Chrome settings need a complete close of Chrome?

10:08 AM, July 17, 2014  
Blogger Beth Safa said...

Is this issue fixed
http://www.forbes.com/sites/ianmorris/2014/07/14/googles-chrome-web-browser-is-killing-your-laptop-battery/

11:35 AM, July 17, 2014  
Anonymous Anonymous said...

We're about to launch a huge project that uses svg assets extensively. This latest update introduces SVG render bugs that put a damper on our plans. Very disappointed.

12:34 PM, July 17, 2014  
Blogger Donis Aviles Juan Carlos said...

Hi I'm having problems with a function on my site known as "autoplay" from a certain time same as youtube does when you share a link with a time specified to start.

It used to work on chrome until your update on June 10th 2014, now it only works on mozilla firefox and internet explorer.

The videos from my site with a time segment won't play anymore, if you can give me any info on the adobe flash player update you did I would be very gratefull to see if I can do some work around on my side to fix it.
Thank you very much.

3:26 PM, July 17, 2014  
Blogger Kai Herlemann said...

@Rama moorthy:
"I hope you are noogler."
That's a exaggeration because it means, workers that have been for a longer time members of the Google staff, shouldn't do any mistakes.

5:46 PM, July 17, 2014  
Blogger Michael Staake said...

After updating from 35 to 36, it's now horribly slow. Tried disabling plugins, resetting, reinstalling, unable to resolve. Firefox and IE work fine. On a 50Mbps internet...

9:59 PM, July 17, 2014  
Blogger Michael Staake said...

Really slow after doing the update from 35 to 36.

10:00 PM, July 17, 2014  
Blogger D.Smithee said...

What happened to the 'check for server revocation' checkbox under the HTTPS/SSL Manage Certificates in settings?

10:20 PM, July 17, 2014  
Blogger terrificTT said...

This new update has slowed the browser than before in my ubuntu 14.04 system...some fonts have changed and moreover google and its associated sites sites are loading at a sluggish speed even on a broadband connection.

5:03 AM, July 18, 2014  
Anonymous Anonymous said...

Has anyone else noticed that tabs do not seem to want to load at all or load very slowly unless you are active in that tab? As soon as you make a tab your focus it will load content as quickly as I would normally expect.

For example if you control-click several links to open them in a new tab none of the tabs will actually load any content (tab title just says "Loading...") until you click into the tab.

I haven't had time to try this on a different computer yet, but I did notice it after this update and was curious if anybody else was experiencing this?

5:51 AM, July 18, 2014  
Blogger Alex Lim said...

The SVG rending bugs are really causing us problems too. I hope this gets fixed quickly.

6:04 AM, July 18, 2014  
Anonymous Anonymous said...

It seems that css underline rendering changed in this release. When using Verdana with a 1px solid underline, the underline actually touches the text while in other browsers (Firefox, Safari) the underline still shows 1px beneath the text, as intended.

I'm experiencing this behavior in OSX Mavericks in Chrome 36.0.1985.125

7:11 AM, July 18, 2014  
Blogger Chris Sweeney said...

The update of chrome to this version for windows xp has broken the touch interface for us inside java applets. Scrambling to find a fix.

8:47 AM, July 18, 2014  
Blogger Anz Joy said...

This version of chrome in incompatible with windows 8.1..
Alawys shows an error 'Cannot start.plz check the filepath'.
reinstalled and the problem persist

8:50 AM, July 18, 2014  
Blogger Sant Sarovar said...

pls remove the google search bar below the address bar. what purpose
it serve if engine is already integrated with address bar. this will be in line with your promise of
simple and clean or tidy interface.

2:21 PM, July 18, 2014  
Anonymous Anonymous said...

Huge +1 for SVG bug, our styles are really messed up, this is a big problem for us, and wasn't happening on Chrome 35 or any other browser, please help with it!
On a first glance it seem the height of SVG elements for expanded by a lot, we are using D3

8:35 PM, July 18, 2014  
Blogger Sam Scott said...

@D.Smithee good catch.

Google, is the check for server certificate revocation always on, now that there isn't a checkbox for it?

This would seem an important enough change to merit a mention in the blog.

11:15 PM, July 18, 2014  
Blogger The Blog Author said...

There definitely ARE some UI improvements like when you move your cursor to the bottom where you see the message displaying the status of the browser.

Earlier it used to remained glued to the bottom of the page and sometimes, you'd miss the text written behind it. Now, however, it slides down whenever you take your cursor there.

2:37 AM, July 19, 2014  
Blogger D.Smithee said...

@Sam Scott

I'll assume it has something to do with Heartbleed. The browser should be checking for server revocation by default, anyway.

4:11 AM, July 19, 2014  
Blogger Ali arif said...

Find Best Online Jobs from Home with Payment Guarantee
www.JobzCorner.com

11:50 AM, July 19, 2014  
Blogger hassan mouse said...

Find best Online Jobs on Facebook...
JobzCorner

6:57 PM, July 19, 2014  
Blogger Edwin Mijnsbergen said...

This update makes chrome very slow :-(

11:15 PM, July 19, 2014  
Blogger Unknown said...

I had to disable hardware acceleration in two Linux computers, since they were both running really slow. Disabling hardware accel restored the usual performance. Both computers use Intel graphics (one is an old ULV celeron, the other is a new Haswell i5).

I tried running from the command line, and I found no relevant clues, so I didn't report a bug, but I thought I'd drop a line.

12:57 PM, July 20, 2014  
Blogger Leo M said...

I see some people also complaining of slow chrome after the upgrade 35->36. Try this: Settings, and search for Hardware. Unselect the option "
Use hardware acceleration when available"

1:03 PM, July 20, 2014  
Blogger TAN KUNHANG said...

omg.. Revolution Slider doesn't display correctly after this

6:15 PM, July 20, 2014  
Blogger genericpenguin said...

+1 for underline bug on OS X (Robin van Baalen). Very annoying. Hope this gets fixed soon.

9:55 PM, July 20, 2014  
Blogger Amit Kumar said...

i am facing problem in playing jplayer after chrome update (36). It was working fine earlier (35)

1:14 AM, July 21, 2014  
Blogger Carlos Valdecantos said...

This comment has been removed by the author.

6:33 AM, July 21, 2014  
Blogger Carlos Valdecantos said...

With the new version, i've found a lot of issues when the css3 transform-origin property is changed.

Pages that used to display properly, now have changed the origin property to the default value (50,50) to all the items so they don't displayed well.


This is a bug or a new way to work with this css property?

6:34 AM, July 21, 2014  
Anonymous Anonymous said...

Disabling hardware acceleration solved my Chrome slowness issues as well as my "tabs not loading" issue mentioned in an earlier comment.

Thanks to everyone who suggested this fix.

For what it's worth I am running Windows 8.1 x64 on a VDI without a dedicated graphics card.

7:00 AM, July 21, 2014  
Blogger Syed Kazim Ali said...

Online Business with hourly profit, Just Invest and Rest
AllTimeProfit.com

7:06 AM, July 21, 2014  
Blogger camoby said...

Thank you for BREAKING Chrome. Again.

Is seems that the jQuery 'jPlayer' html5 media plugin has broken since you FORCED this update on us on Wednesday.

9:55 AM, July 21, 2014  
Blogger Boyd Badten said...

As noted above, jQuery jPlayer media player is broken by Chrome v36. I just noticed the same thing happening on my Android phone too. Google developers---please fix this bug. jPlayer is all over the place and the other browsers all handle it just fine. My organization uses jPlayer a lot on our site. Please give me a reason not to tell unhappy visitors to switch to Firefox....

11:30 AM, July 21, 2014  
Anonymous Anonymous said...

@Julian Xhokaxhiu: what operating system do you use? 64bit versions of Chrome 36 are not available. wait for the next version of Chrome instead which will be available for both 32bit & 64bit editions.

@Irbidan: you must wait for Chrome 37 as there won't be a 64bit stable release of Chrome 36. I'm currently trying out a 64bit version of Chrome 37 beta.

1:39 PM, July 21, 2014  
Blogger Hadi Katebi said...

Somehow you screwed up ogg vorbis streaming. It stops after every song. MP3 seams to be working fine.

2:49 PM, July 21, 2014  
Blogger Celeza said...

Still does not support HIDPI... :(

8:03 PM, July 21, 2014  
Blogger meksONE said...

I confirm that Revolution Slider (from themepunch.com) doesn't work correctly after this update. Also, variuos jQuery-based plugins on WordPress behave strangely.
It's a REALLY BIG problem: hundreds of thousands websites rely on WP/JQuery so... please fix!

7:29 AM, July 22, 2014  
Blogger Jeff kr said...

This update broke our chrome. All5 of our PC's using matrox m9128 video cards now just get black screens. Every thing is black including the Omni box. we have to put in the command line --disable-gpu to get them to work at all , but then cant open links because the don't use the command line. cant find anywhere to make disable-gpu global. it all worked fine till this update.

8:07 AM, July 22, 2014  
Blogger Jeff kr said...

This update broke our chrome. All5 of our PC's using matrox m9128 video cards now just get black screens. Every thing is black including the Omni box. we have to put in the command line --disable-gpu to get them to work at all , but then cant open links because the don't use the command line. cant find anywhere to make disable-gpu global. it all worked fine till this update.

8:08 AM, July 22, 2014  
Blogger Unknown said...

Since version 36 is installed Chrome is terribly slow. There is a keyboard lag in every site i can type or click things (like eg. this text-box), also the scrolling of pages does not go fluently, so i mis-click several times per day.

I tried several options, like disabling all plugins, disabled spell-check etc. but the problem remains. Also the beta versions of 37 or 38 dev, still have this issue.

8:19 AM, July 22, 2014  
Blogger Carlos Candido said...

There's several problems envolving this version and applications running on JBoss Enterprise Application using richfaces 3.3.x.

1:16 PM, July 22, 2014  
Blogger Karen Banning said...

I thought it was just me. Have called cable company twice. Slow connection along with slow searches...I type all over myself...this is driving me crazy. Any fixes on the horizon?

10:42 AM, July 23, 2014  
Blogger Richard Collette said...

Broken jQuery animations

https://code.google.com/p/chromium/issues/detail?id=395213

https://code.google.com/p/chromium/issues/detail?id=396746

12:11 PM, July 23, 2014  
Blogger Rachkoud said...

We encountered performance issues with some of our users who updated Chrome to 36.0.1985.125. By disabling hardware acceleration, the usual performance were restored.

12:03 AM, July 24, 2014  
Blogger HG Ent. said...

All about Internet Learning and Information visit

http://humzagroup.blogspot.com
http://pkvacancies.blogspot.com
http://livepmtv.blogspot.com
http://itools.humzagroup.com/imagehost/
http://itools.humzagroup.com/resize/
http://itools.humzagroup.com/html2java.php
http://todaypricelist.blogspot.com
http://prizebondhints.blogspot.com

Keep Visit for Live TV Channels and Price List, Prize Bond, Free Scripts, Jobs, Earn Money Online, Paypal Verified Account Method and Much more....

4:40 AM, July 24, 2014  
Blogger HG Ent. said...

All about Internet Learning and Information visit

Toturials and E Learning
Online Jobs, Careers, Vacancies
Watch Live Free TV Channels Online
Free Image Hosting Online
Free Images Resize Online
HTML to Java Converter Online Free
Latest Daily Price List Updates
All about Prize Bond, Guess, Resuts,Tips

Keep Visit for Live TV Channels and Price List, Prize Bond, Free Scripts, Jobs, Earn Money Online, Paypal Verified Account Method and Much more...

4:40 AM, July 24, 2014  
Blogger JM said...

This comment has been removed by the author.

6:42 AM, July 24, 2014  
Blogger JM said...

What about H264 videos that doesn't work anymore ?

http://www.quirksmode.org/html5/tests/video.html

6:43 AM, July 24, 2014  
Blogger Mauricio López said...

Good news to know that!, thanks

12:27 PM, July 24, 2014  
Blogger Jateen Mahapatra said...

What are under the hood changes ?

3:09 PM, July 24, 2014  
Blogger Terry O'Hagn said...

update 36 has broken word predictin with win7 onscreen kb. essential to many disabled

8:56 PM, July 24, 2014  
Blogger gaxweb said...

It broke the filter menu on the left at http://shop.ricosta.de/de-de/products?gender=M

1:40 AM, July 25, 2014  
Blogger Martin Oss said...

This release messes up my svg's too. They render way too big

7:43 AM, July 26, 2014  
Blogger christian peixoto said...

Is there a Java support for Linux in this new version? I am still using the 34.

8:10 PM, July 26, 2014  
Blogger isacfmaia said...

There's several problems envolving this version and applications running on JBoss Enterprise Application using richfaces 2.3

Estou com problemas no file upload do JBOSS 4.2.2 usando o richfaces 2.3

12:55 PM, July 28, 2014  
Blogger MacGuruTX said...

I too experience a COMPLETELY black chrome screen after this upgrade. I couldn't even get the uninstaller to be viewable.

After noticing JeffR remarks on a Matrox 9128. I'm running Matrox 9148 cards on Win7 x64.

After uninstalling the Windows Certifed Driver (WHQL) and switching to the XDDM SE driver, I'm now able to see Chrome again.

5:05 PM, July 28, 2014  
Blogger Boyd Badten said...

Here is a major bug with Chrome 36 which I haven't read about yet. In my eCommerce application (AbleCommerce) there are financial reports with the option to "download as Excel or CSV"--a very common and helpful feature. With Chrome36 this download as Excel feature is broken---it yields a download dialog box, but it is configured to down the aspx file of the report page--not the Excel file. There is no way to make it work correctly, although the feature works fine with Firefox, Safari and IE (all recent versions). Chrome developers, I am about to abandon Chrome as my primary browser due to this mounting list of common things that I need to use which are broken now in v36. In addition to this download dialog issue I'm seeing many different jQuery applications broken--once again, on sites including my own. I'm about ready to bail and start using Firefox as my primary. Do you care? Do you test this stuff? Or are we the alpha testers?

8:07 AM, July 30, 2014  

Post a Comment

Subscribe to Post Comments [Atom]

<< Home