Tuesday, August 27, 2013

Dev Channel Update

The Dev Channel has been updated to 31.0.1612.0 for Mac and Linux, and 31.0.1612.1 for Windows and Chrome Frame .

This release fixes a number of crashes and other bugs. A full list of changes is available in the SVN log. Interested in switching release channels? Find out how. If you find a new issue, please let us know by filing a bug.

Anthony Laforge
Google Chrome

Labels:

57 Comments:

Blogger Ron Waldon said...

Weird. I'm still on "Version 30.0.1599.14 dev". Usually I'll see the coloured hamburger menu button for the update _before_ I read about it. :) Now the waiting game begins. :)

6:39 PM, August 27, 2013  
Blogger ramsy said...

this version was so bad! my pc(windows7)was overheated.chrome.exe was eating all cpu power!

6:48 PM, August 27, 2013  
Blogger Stanzilla said...

super broken build, 100% cpu usage all the time

6:56 PM, August 27, 2013  
Anonymous Anonymous said...

I think we should use Shiflt + Esc to find the process that makes my cpu 100%.
Finally, I find "Instant: NewTab" process cause problem.

7:07 PM, August 27, 2013  
Blogger Nguyen Huy Anh said...

I see the version on my machine is 31.0.1612.1 dev-m Aura... is that some hidden Easter egg or something?

8:54 PM, August 27, 2013  
Blogger lavieu said...

The worst update ever.

9:36 PM, August 27, 2013  
Blogger Alen said...

The browser is causing the cpu to run 100% all the time. Can't use it now until there is a fix.

9:55 PM, August 27, 2013  
Blogger Oleg Anashkin said...

Each tab uses 3-5% CPU, so overall browser consumes 100% CPU and makes the whole system unresponsive. Can't use Chrome now at all.

9:57 PM, August 27, 2013  
Blogger Ishmoo21 said...

My theme basically went away when switched to 31.0.1612.1 dev-m Aura. The bar is blue and now there is a blue A on my menu button

9:58 PM, August 27, 2013  
Blogger Ishmoo21 said...

And I am running 100% too.

9:59 PM, August 27, 2013  
Blogger Nolo said...

The 100% Bug seems to be a Rendering Bug, since Deactivating all Plugins, and phishingfilters (like what helps to get less cpu in the Past) didn't even give a tick less CPUtime here.

Someone relay messed up here, and i hope they will update that asap.

10:09 PM, August 27, 2013  
Blogger Ronald said...

Can't work with 16:9 screens

10:12 PM, August 27, 2013  
Blogger José Adolfo Galdámez Recinos said...

CPU at 70% - 80%, when the normal thing 2% or 3%, Please Fix!

10:22 PM, August 27, 2013  
Blogger rt said...

Issue 280205: Renderer processes consume 100% CPU in compositor
https://code.google.com/p/chromium/issues/detail?id=280205

10:38 PM, August 27, 2013  
Blogger Mark Polyakov said...

dev 31 aura????? what is that? Also, my old theme broke. I got a new one and it is working, but i miss my old one :(

11:18 PM, August 27, 2013  
Blogger Zaharia Constantin said...

This comment has been removed by the author.

11:19 PM, August 27, 2013  
Blogger Zaharia Constantin said...

same here, 100% process, and way Aura? that is the catch?

11:21 PM, August 27, 2013  
Anonymous Anonymous said...

This comment has been removed by a blog administrator.

12:23 AM, August 28, 2013  
Anonymous Anonymous said...

This comment has been removed by a blog administrator.

12:24 AM, August 28, 2013  
Anonymous Anonymous said...

i got this version Version 31.0.1612.1 dev-m Aura. But It's got serious keyboard issues while opening it in metro mode. Chrome can't detect any alphabetic keys, only numerals. If we type any alphabetic key, it shows only some random numbers. Why is that?

12:37 AM, August 28, 2013  
Blogger Steven Spyrka said...

100% CPU too, please fix :)

12:46 AM, August 28, 2013  
Blogger Andrea said...

Tipyng alphebetic key it shows only number. Bad version.

12:58 AM, August 28, 2013  
Blogger Sara Uzzina Marchi said...

Disaster! Full of bug, how can i disable windows 8 mode? Typing a letter it shows number. Please update!

1:39 AM, August 28, 2013  
Blogger Drakaris said...

100% CPU usage, all addons completely broken, themes gone... That's the worst update EVER...

2:22 AM, August 28, 2013  
Blogger Filogo said...

100% CPU usage too...please FIX it soon. And no chrome remote desktop functionality anymore.

2:52 AM, August 28, 2013  
Blogger Giuliano Tomiazzo said...

Same problem for me: 100% CPU usage. Unusable!

3:20 AM, August 28, 2013  
Blogger Domenl said...

No problems here. Windows 8 Pro 64-bit. CPU usage minimal, just as always

3:27 AM, August 28, 2013  
Blogger Firewalker said...

If you disable the Instant Extendend API the CPU problem is gone!

3:33 AM, August 28, 2013  
Blogger skywolf said...

window 8 version31.0.1612.1 dev Aura so many problems ... metro mode and desktop bug ... Whoa! Google Chrome has crashed. Relaunch now? ... relaunch chrome restart again ... troublesome...

3:36 AM, August 28, 2013  
Blogger iron2000 said...

An Aura build!
Read about it on G+, finally got to run it.

Anyway Aura is not some easter egg or something :P
From what I understand is something like Aero in Windows, something to do with UI.

Aura came from the Chrome OS side.

For deeper details go Google it ;)

3:45 AM, August 28, 2013  
Blogger Vincent said...

100% CPU usage here too,
somehow I can't disable the Instant Extendend API to test if it would fix the problem :(

4:04 AM, August 28, 2013  
Blogger Once Upon A Time said...

100% cpu usage immediate after upgrading on windows 7.

Firewalker said...
If you disable the Instant Extendend API the CPU problem is gone!

It's not gone, I didn't enable this option.

4:52 AM, August 28, 2013  
Blogger Peter Nimmo said...

Same here. Ever since getting this update with the "a" on the settings button the CPU usage has gone through the roof, and I don't have the Instant Extended API option enabled

5:52 AM, August 28, 2013  
Blogger Drakaris said...

Reverted back to beta channel. The dev version is not usable for me, my whole PC becomes unusable because of that. v30 works perfect.

5:57 AM, August 28, 2013  
Blogger Handycam said...

Same here with the 100% CPU use, even in background. Mac OS 10.8.4. Meanwhile Safari background CPU use is about 2%. Went back to 29 but now it seems that even 29 is having high CPU use -- above 85% in background. I checked Chrome task manager and all of that CPU is the Browser process.

5:59 AM, August 28, 2013  
Anonymous Anonymous said...

31.0.1612.1 dev-m Aura keyboard is not working on my laptop. Cannot type in the address bar, when trying to write in any fields on the page is seems like my keyboard works like a numpad.

6:05 AM, August 28, 2013  
Blogger Thomas Quintana said...

This morning my system updated to: Version 31.0.1612.1 dev-m Aura

With that update I noticed that my theme that I had previous has gone back to the default. And I also noticed that the App launcher in the top left corner has disappeared.

Hmmmm.

6:11 AM, August 28, 2013  
Blogger iron2000 said...

So far no problem on my Win 8 Pro x64 PC.

The metro mode feels like Chrome OS.

6:29 AM, August 28, 2013  
Blogger Andrew Arace said...

very unstable. (win8, running in desktop mode). consistently crashes
i'm a firm believer in the dev channel, but this doesn't even look like it was tested for 5 minutes.
might have to revert.

6:30 AM, August 28, 2013  
Blogger iron2000 said...

Ok, I can't type in the omnibar of Metro mode Chrome.
I can backspace but can't type.

Strangely on the desktop its holding out pretty well, used it for hours fine.

I suppose the move to Aura is a big change thus causing those bugs, its the dev channel after all.

But if its the stable channel then its complaining time.

6:42 AM, August 28, 2013  
Blogger Kyle McNally said...

Star this bug if you have the 100% CPU problem: https://code.google.com/p/chromium/issues/detail?id=280205

6:48 AM, August 28, 2013  
Blogger ezybzy said...

It is hold, isn't it?

7:24 AM, August 28, 2013  
Blogger Nguyen Huy Anh said...

Figured out that Aura is a UI implementation from the Chrome team. Noticed lots of subtle animations :) By the way I didn't seem to experience any bugs on my Windows 8 netbook...

7:54 AM, August 28, 2013  
Blogger Dan Atkinson said...

I also experienced the 100% CPU. A quick fix for this is to go through all of the tabs, which immediately reduces their CPU usage.

As noted by others, Aura is the new UI implementation.

Bug has been raised here: crbug.com/280544. Please star the issue to raise its awareness.

8:10 AM, August 28, 2013  
Blogger Astrophizz said...

Does Aura mean Windows will finally get the same tab animations as on Macs?

8:25 AM, August 28, 2013  
Blogger Alexander Lingtorp said...

I too have the problem of extreme CPU usage. Also my theme broke, but that okay. :)

9:48 AM, August 28, 2013  
Blogger Bijan Albuyeh said...

To go back to your older, working version of chrome. Go to start > run, and type in "%userprofile%\AppData\Local\Google\Chrome\Application" without the quotes. Run old_chrome.exe :)

10:34 AM, August 28, 2013  
Blogger Bob Chuck said...

This build broke all sorts of things. LogMeIn does not work right, scrolling with my mouse wheel works 50% of the time, high cpu, and my theme disappeared.

12:49 PM, August 28, 2013  
Blogger Wise Ass said...

This comment has been removed by the author.

1:14 PM, August 28, 2013  
Blogger Wise Ass said...

The problem relates to the prerendering of pages. If you disable prerendering and end all ongoing prerendering processes, the problem goes away

1:19 PM, August 28, 2013  
Blogger bernhold said...

Please fix "a" symbol in menu :)

1:41 PM, August 28, 2013  
Blogger Jerrett Longworth said...

I noticed something... Check this out.

http://goo.gl/FyBmpF

2:58 PM, August 28, 2013  
Blogger Jerrett Longworth said...

P.S. It works just fine with 5% CPU usage.

3:00 PM, August 28, 2013  
Blogger Admin said...

31.0.1612.2

Check for new_chrome.exe in C:\Program Files (x86)\Google\Chrome\Application or your PC.

It fixes the CPU problem.

10:59 PM, August 28, 2013  
Blogger Admin said...

This comment has been removed by the author.

10:59 PM, August 28, 2013  
Blogger Mink me said...

Advertise With Minkme
Sign up on MinkMe with your phone and create a group, connecting and promoting your brand. Business development with social media and muchs more.
Click Here To Download Free App
Take A Look @ Mink Display
Join With us on Facebook
Tweet With us on Twitter

5:42 AM, August 29, 2013  
Anonymous Anonymous said...

the Aura is gone now.. back to 31.0.1612.2 dev-m. Works fine now!

6:31 AM, August 29, 2013  

Post a Comment

Subscribe to Post Comments [Atom]

<< Home