Tuesday, March 15, 2011

Stable and Beta Channel Updates


The Chrome Stable and Beta channels have been updated to 10.0.648.134 for Windows, Mac, Linux and Chrome Frame. This release contains an updated version of the Adobe Flash player. If you find new issues, please let us know by filing a bug. Want to change to another Chrome release channel? Find out how.

Jason Kersey
Google Chrome

Labels: ,

15 Comments:

Blogger Thomas said...

I have a problem with the latest stable release that sometimes the URL is disappearing from the omnibar which is a problem if I want to copy and paste it.

1:28 PM, March 15, 2011  
Blogger Western Hospitality Singers said...

This comment has been removed by the author.

2:38 PM, March 15, 2011  
Anonymous Anonymous said...

Thomas: if you have extension Speed Dial, disable it or reinstall it. This is bug in this extension

2:43 PM, March 15, 2011  
Blogger XxxxxX said...

Why stable and beta are the same version now?

2:46 PM, March 15, 2011  
Blogger Tom said...

Why are there 2 versions of flash installed??

2:59 PM, March 15, 2011  
Blogger csa said...

Does this fix http://www.adobe.com/support/security/advisories/apsa11-01.html ?

3:52 PM, March 15, 2011  
Blogger ganesh said...

If this release fixes flash zero-day mentioned in http://www.adobe.com/support/security/advisories/apsa11-01.html, when will the dev channel have it?

4:53 PM, March 15, 2011  
Blogger Ðavis said...

i have version 11 right now, they need to update this!

9:21 PM, March 15, 2011  
Blogger ElGreco said...

Does this version fix the Flash crashing?

1:17 AM, March 16, 2011  
Blogger ragnarok said...

Youtube videos do not load with the newest flash. I thought it was my adblocking extensions so I uninstalled, but it still didn't load.
I went to about:plguins and disabled the built in flash and youtube loads.

I have not tested with any other flash video websites.

5:55 PM, March 16, 2011  
Blogger Lanel said...

Maybe you should unlink Flash from your browser.

10:25 AM, March 17, 2011  
Blogger ` said...

Since upgrading to the latest stable I've been gettinga "Error 324 (net::ERR_EMPTY_RESPONSE): Unknown error" on many websites across all browsers. Not certain if it's related to the recent update.

10:26 AM, March 17, 2011  
Blogger barnpiece said...

Does not fix the Shockwave Flash plugin crashes problem.

10:58 AM, March 17, 2011  
Blogger Sue said...

The Forum is full of unhappy people frustrated with the Shockwave Flash plugin problems.
Any news on a fix?

8:38 AM, March 18, 2011  
Blogger Everett said...

My Shockwave crashed yesterday, Monday; Windows 7 updated, 64-bit, Shockwave 10.2. Evidently Adobe still isn't corrected.

12:20 PM, March 22, 2011  

Post a Comment

Subscribe to Post Comments [Atom]

<< Home