Thursday, April 17, 2014

Beta Channel Update for Chrome OS

The Beta channel has been updated to 35.0.1916.47 (Platform version: 5712.29.0) for all Chrome OS devices. This build contains a number of bug fixes, security updates and feature enhancements. Here is the chromium changelog.

If you find new issues, please let us know by visiting our forum or filing a bug. Interested in switching channels? Find out how. You can submit feedback using ‘Report an issue...’ in the Chrome menu (3 horizontal bars in the upper right corner of the browser).

Dharani Govindan
Google Chrome

Labels: ,

9 Comments:

Blogger Glendo B. said...

Thank you for fixing the slow startup issue my samsung arm chromebook is booting very fast again. I am testing videos and other stuff to make sure everything else seems ok or improved. If i find any issues i will post them.

9:09 PM, April 17, 2014  
Blogger Samantha Parker said...

Really Nice Commment I am Bangalore Escorts Samantha

2:36 AM, April 18, 2014  
Blogger Samantha Parker said...

Really Nice Commment I am Bangalore Escorts Samantha

2:37 AM, April 18, 2014  
Blogger Daniel Sharon said...

The slow startup time has been fixed but the sluggish YouTube performance hasen't. Please fix it in the next release in the beta channel. Samsung Series 3 ARM Chromebook

5:31 AM, April 18, 2014  
Blogger miguel said...

I second that. Youtube .

11:03 PM, April 18, 2014  
Blogger Marty Goetting said...

No wifi reconnect after sleep, power off required to restore connection.

9:44 AM, April 20, 2014  
Blogger Glendo B. said...

I am also seeing some issues with youtube videos as well. There are some i have had no issues with then a couple times it loaded the audio and not the video just a black screen. After refreshing page it was ok but does seem to be the odd glitch in youtube videos on my samsung arm chromebook. I don't really watch many youtube videos mostly netflix, hulu, sports sites, etc. which all use different video players from youtube. I have had no issues with those videos and the performance of the chromebook seems fine to me as well.

1:17 PM, April 20, 2014  
Blogger IainGT said...

Have submitted a bug for this, but want to know if others are having the same issue with Keep.

It keeps crashing basically. Will open briefly, try to load and crash. Was fine before the update on 10th April.

2:22 AM, April 22, 2014  
Blogger Me said...

I had the wifi problem as well. Had to go back to the stable version because of it.

6:06 AM, April 29, 2014  

Post a Comment

Subscribe to Post Comments [Atom]

<< Home