Thursday, July 17, 2014

Beta Channel Update

The Chrome team is excited to announce the promotion of Chrome 37 to the beta channel with 37.0.2062.20 for Windows, Mac and Linux. (Chrome 64-bit for Windows will be coming to the beta channel shortly, stay tuned!)

This release contains many stability and developer improvements including:
  • DirectWrite support on Windows 
  • Redesigned "Save Password" UI
  • Automatic reload of unreachable pages when network becomes available 
  • Dropped Chrome sign-in requirement for Chrome Apps 
  • A number of new apps/extension APIs 
  • Lots of under the hood changes for stability and performance 

A full list of changes in this build is available in the SVN log. Interested in switching release channels? Find out how. If you find a new issue, please let us know by filing a bug.

Alex Mineer
Google Chrome

Labels:

28 Comments:

Blogger Sterling said...

Congrats on Chrome 37!

10:17 AM, July 17, 2014  
Blogger manohar viswanatha said...

Will chrome ever provide an option the run the executable files downloaded directory like IE and Firefox instead of saving every bit and piece and messing up the hard drive ?

10:44 AM, July 17, 2014  
Blogger Mohan Singh said...

My windows 8 computer shows problems with this new beta version, the graphics is not rendered correctly. Am moving to stable version.

10:50 AM, July 17, 2014  
Blogger Anthony Aquino said...

I'm on the same boat as Mohan Singh. I'm on Windows 8.1 and my native resolution is 1920x1080 and Chrome resized itself as if it were on a 1366x768 screen after the update. I'm going to have to move to stable too.

1:08 PM, July 17, 2014  
Blogger Floego said...

I have a tab freezing issue. I'm running win7 x64.

2:51 PM, July 17, 2014  
Blogger Bryce Platt said...

This comment has been removed by the author.

5:33 PM, July 17, 2014  
Blogger Pablo Massa said...

I have a tab freezing issue. I'm running win8.1 x64.

8:06 PM, July 17, 2014  
Blogger stamprsist said...

Very really slow, and difficulty to load page. I'm running win8.1 x64.

6:02 AM, July 18, 2014  
Blogger dhtuuu said...

what do you guys mean with "tab freezing" issue? Could you explain how to reproduce it please ?

6:36 AM, July 18, 2014  
Blogger Floego said...

For 'freezing' I mean that an 'opening new tab' action hangs the browser for about 4 seconds, you can't use it, it is totally irresponsive. Switching between tabs also gets the "freezing" effect. It is really annoying.

8:28 AM, July 18, 2014  
Blogger Alex Mineer said...

Re: tab freezing, we're actively working on this issue at https://code.google.com/p/chromium/issues/detail?id=381820 - if you can replicate it, please review comments #44 and #75, we'd love to have a trace captured of the problem.

Mohan, Anthony, if you could file a bug report (including screenshots) for the resolution issues you are experiencing, it would be appreciated.

9:17 AM, July 18, 2014  
Blogger Guilherme Tonioli said...

Developer tools stop work.
When I open, a blank page replaces the page content.

3:56 PM, July 18, 2014  
Blogger PBarnum said...

As Anthony Aquino said, The window resolution has increased dramatically making text 'fuzzy' and a pain to read. Please fix the issue!

5:17 PM, July 18, 2014  
Blogger THEKILLER7777 said...

Hi - Yeah my tabs random freeze too. Biggest issue is when I move them along or into a separate window. I am running Windows 7 x64

3:59 AM, July 19, 2014  
Blogger DavidTiger said...

Experiencing massive tab lagging, pages opened in a new tab in the background are slow to load, youtube stutters if on another tab.. I just bought a new GPU and thought this was the problem. Going to have to switch back to a stable build until these issues are resolved :)

5:54 PM, July 19, 2014  
Anonymous Anonymous said...

Regarding "Automatic reload of unreachable pages when network becomes available", is there some special settings toggle I should tweak? Have turned Wi-Fi off, started Chrome, lots of "Unable to connect to the Internet" tabs appeared, turned Wi-Fi on, none of them reloaded. Using 37.0.2062.20 on OSX 10.9.4.

1:13 AM, July 20, 2014  
Blogger Biohazard707 said...

fuzzy fonts.

6:56 AM, July 20, 2014  
Blogger Mohan Singh said...

Passwords are not getting auto-filled at some sites like www.chase.com

10:20 AM, July 20, 2014  
Blogger Mohan Singh said...

Passwords are not getting auto-filled at some sites like www.chase.com. This used to work earlier. On top right of screen, there shows a popup "Manage your passwords" that saved username and password exists, but there is no way to get the username and password from that popup, filled into the username and password fields.

10:22 AM, July 20, 2014  
Blogger Mohan Singh said...

My windows 7 computer shows problems with this new beta version, the graphics is not rendered correctly. Seems to be GPU related. Am moving to stable version. I would have added screenshot, but it is difficult to create and share that screenshot

10:23 AM, July 20, 2014  
Blogger SeuAndré said...

Really slow on most websites (e.g. gmail). Running win8.1 x64.

3:10 AM, July 21, 2014  
Blogger leggyorlyb said...

Chrome has been freezing and not responding then it starts this constant flashing and blinking and i have to shut it down through task manager. When I restart it and hit restore , it will do it again then I have to shut down with task manager again, when I finally get it to working again, i've lost all my open tabs and it's really frustrating. Just started doing this periodically about 3 or 4 days ago.

9:52 AM, July 21, 2014  
Blogger Mohan Singh said...

Filed screenshot in Issue 395691

11:03 AM, July 21, 2014  
Blogger Mohan Singh said...

Filed screenshot in Issue 395691.
Seems to be GPU related. Note the black bar near top of screenshot, that goes over the profile icon(image on top left) as well

Screenshot at https://code.google.com/p/chromium/issues/detail?id=395691&thanks=395691&ts=1405965793

11:04 AM, July 21, 2014  
Blogger Bob K. said...

My digital newspaper, The Oregonian of Portland OR, does not work with Chrome. I just tried Chrome 37 and it still doesn't work.
Works fine via I.E. & Firefox..

http://digital.olivesoftware.com/Olive/ODE/oregonian/

Anyone know what the problem is.

4:52 PM, July 21, 2014  
Blogger Lordblacksuca said...

As the other users, I am running Windows 8.1 chrome x64, and there is a massive lag when I open an old tab (few minutes after).

2:33 PM, July 22, 2014  
Blogger ßłưε˅ỉžỉơƞş said...

Everyone who has an issue with the screen resolution increase/Fonts,Icons,Text etc... needs to go here https://code.google.com/p/chromium/issues/detail?id=394967 and post there issues so they can fix this problem.

8:41 PM, July 22, 2014  
Blogger Pap Sandor said...

It's slow as hell... For example.. I have two tabs opened. I'm on the first. I click tab 2, and I have to wait 1 second, until it change... It has a LAG... It's very annoying
The same problem when I open a new empty tab... Or if I open google.com, it takes 3-4 seconds... Theres nothing happens, after that it start to work... I have 200 mbps internet, a good PC, and other browses make actions in that moment, when I click. This beta version of Chrome doesnt't do the same...

12:43 PM, July 30, 2014  

Post a Comment

Subscribe to Post Comments [Atom]

<< Home