Thursday, February 5, 2015

Stable Channel Update

The stable channel has been updated to 40.0.2214.111 for Windows, Mac and Linux. A full list of changes is available in the log.

Security Fixes and Rewards
Note: Access to bug details and links may be kept restricted until a majority of users are updated with a fix. We will also retain restrictions if the bug exists in a third party library that other projects similarly depend on, but haven't yet fixed.

This update includes 11 security fixes. Below, we highlight fixes that were contributed by external researchers. Please see the Chromium security page for more information.

  • [$25633.7][453979High CVE-2015-1210, CVE-2015-1211: A special reward to anonymous for cross-origin-bypass in V8 bindings and privilege escalation using service workers.
  • [$5000][447906High CVE-2015-1209: Use-after-free in DOM. Credit to Maksymillian Motyl.
As usual, our ongoing internal security work was responsible for a wide range of fixes:
  • [455225] CVE-2015-1212: Various fixes from internal audits, fuzzing and other initiatives.
Many of the above bugs were detected using AddressSanitizer or MemorySanitizer.

Interested in switching release channels? Find out how. If you find a new issue, please let us know by filing a bug.

Daniel Xie
Google Chrome

Labels:

18 Comments:

Blogger Abdalrhman mohamed said...

good google chrome

3:00 PM, February 05, 2015  
Blogger Vig said...

Hey guys, great work with the browser updates and security patches. I have always wondered though, the version on the IPad has not changed from *.69 to *.111 as it should be. Any dates on the release in IPad? Thanks.

4:25 PM, February 05, 2015  
Blogger Dan Walker said...

Version 40.0.2214.93 m

Update failed (error: 7)An error occurred while checking for updates: The installer encountered error 35.

4:59 AM, February 06, 2015  
Blogger Purple Blades said...

I'm thankful for all the security updates, but I have to say what you did with the buttons on the new tab page is horrendously ugly. Will be finding an app that is closer to the previous style.

5:31 AM, February 06, 2015  
Blogger Heitor Teixeira said...

I see in some cases, some YouTube videos play but does not appear video images. I think would be a case to study. Since Google Chrome 40 version this is happening. Hope helped.

6:58 AM, February 06, 2015  
Blogger unknownman72 said...

Now, with this update the lags on YouTube disappear. But another problem with this update is, that in videos on YouTube isnĀ“t any gap between the link with picture and name of the YouTube channel and the main title. But thanks for fix lagging on Youtube. You did good work now, keep it up Google. Bye.

7:16 AM, February 06, 2015  
Blogger unknownman72 said...

But in 1080p it is lagging a bit still.

11:50 AM, February 06, 2015  
Blogger Red Rock said...

This comment has been removed by the author.

7:43 PM, February 06, 2015  
Blogger Red Rock said...

Version 40.0.2214.111 m (64-bit)

Update failed (error: 7)An error occurred while checking for updates: The installer encountered error 35.

7:45 PM, February 06, 2015  
Blogger Dan said...

Getting the same problem:

" Update failed (error: 7)An error occurred while checking for updates: The installer encountered error 35."

6:47 PM, February 07, 2015  
Blogger Erlinda Natalia said...

Tanks for informations

Best regards,
erfashionimage.blogspot.com

1:08 AM, February 08, 2015  
Blogger None said...

This comment has been removed by the author.

2:25 AM, February 09, 2015  
Blogger Alistair Toomey said...

Trustwave Repport does not work correctly after this update

2:51 AM, February 09, 2015  
Blogger John Sousa said...

I work for a school district, and our Samsung Chromebooks, most recently running:

Version: 38.0.2125.110
Platform 6158.70.0 (Official Build) stable-channel daisy
Firmware Google_Snow.2695.117.0

..have not been auto-updating. The only way they update is if I log in and forcefully do it. I verified that in the admin console, the settings are correctly set to auto-update with no restrictions on version. This is a big problem for school districts.

Any help you can provide would be greatly appreciated.

5:16 AM, February 10, 2015  
Blogger Steve said...

If I click on the links in your blog post, it goes to a 404. The specific links are for the issue numbers (i.e. 453979)

8:38 AM, February 11, 2015  
Blogger . said...

Somehow I cannot log into Massdrop.com. Firefox works fine.

Also, I get the dreaded "Updates are disabled by the administrator". Well, I AM the administrator but Chrome won't auto-update. Nothing else changed on this PC.

I do have to note that it's running Windows 10 build 9926 though, on the fast track.

11:31 AM, February 11, 2015  
Blogger carlo said...

"Purple Blades said...
I'm thankful for all the security updates, but I have to say what you did with the buttons on the new tab page is horrendously ugly. Will be finding an app that is closer to the previous style." - ditto this!

5:30 PM, February 12, 2015  
Blogger mr The said...

How about to fix this bug with gifs/large images?
https://code.google.com/p/chromium/issues/detail?id=439567

2:43 AM, February 13, 2015  

Post a Comment

Subscribe to Post Comments [Atom]

<< Home