Wednesday, October 6, 2010

Dev Channel Update

The Chrome Dev channel release has been updated to 7.0.544.0 for all platforms.  It contains a number of changes including the following updates:

All
  • Make it possible to completely hide sections in the NTP (hit close button that appears on hover of section header)
  • Numerous stability fixes
Mac
More details about additional changes are available in the SVN revision log.  If you find new issues, please let us know by filing a bug. Want to change to another Chrome release channel?  Find out how.


Jason Kersey
Google Chrome

Labels:

62 Comments:

Blogger REO said...

Nice update Google Dev Team!

Win Vista/32 bit

4:05 PM, October 06, 2010  
Blogger Emiya Shirou said...

"Make it possible to completely hide sections in the NTP"

What the hell is NTP O.o?

4:08 PM, October 06, 2010  
Blogger Pinky said...

What is the difference between Dev Channel and Beta ?

4:22 PM, October 06, 2010  
Blogger slipstream said...

@Emiya Shirou

NTP is a shorthand for New Tab Page, and the "sections" mentioned in the changelog are the "Most visited" and "Recently closed" lists.

Btw this is a redesign/reappearance of the previously removed feature. See this feature request for back-story details: Issue 55148: new tab page exposes private information

4:33 PM, October 06, 2010  
Anonymous Anonymous said...

does it include the many new features like instant and gpu acceleration?

4:34 PM, October 06, 2010  
Blogger Avinash Agrawal said...

Wow: nice new labs in about:labs

Page Info Bubble
Shows the Page Information as an info bubble instead of a dialog window.
Disable
Disable outdated plug-ins
Automatically disables plug-ins with known security vulnerabilities and offers update links for them.
Disable
XSS Auditor
Enables WebKit's XSS Auditor (cross-site scripting protection). This feature aims to protect you from certain attacks of malicious web sites. It improves your security, but it might not be compatible with all web sites.
Disable
Background WebApps
Allows installed web apps to run in the background at system startup and continue running after all windows are closed.
Disable

5:00 PM, October 06, 2010  
Blogger Blue said...

Now that I've closed things on the NTP page, how do I get them back?!

5:02 PM, October 06, 2010  
Blogger Jack said...

@Blue look at the bottom of the window

5:27 PM, October 06, 2010  
Blogger slipstream said...

This comment has been removed by the author.

5:31 PM, October 06, 2010  
Blogger Blue said...

@Jack: there's nothing to see.

I've got the bookmark bar at the top of page and the rest is blank. Context menu has nothing relevant. Options has nothing relevant.

5:33 PM, October 06, 2010  
Blogger slipstream said...

@Blue

The closed section(s) would appear as labels/buttons at the bottom-left corner of the New Tab Page.
Like this: http://imgur.com/Ckduj.png

I guess you've stumbled upon the temporary bug - developers forgot to account for the Bookmarks Bar toggle. So if you have Bookmarks Bar disabled (and then it would automatically appear on the NTP) - BAM, both closed sections buttons and Google Chrome logo are dropping offscreen: http://imgur.com/NDVJX.png
Though you can still barely catch a glimpse of them http://imgur.com/XvPeP.png

(reposting due to url typo)

5:40 PM, October 06, 2010  
Blogger Blue said...

@slipstream:

Thanks. You got it - I had Bookmarks Bar disabled / detached. For some reason, I could not see any of the closed section / logo - http://i.imgur.com/37cGK.png

It took me a few seconds to realise that I need to expand and then click on 'Recently Closed' to get it back.

Thanks for your help.

5:43 PM, October 06, 2010  
Blogger dbone said...

i dont know what it is about this build....but for some reason its noticeably faster for me. love it so far.

5:49 PM, October 06, 2010  
Blogger themis said...

Hey, this build made chrome stop working on my Macbook Pro! It seems that the main process stacks somewhere about 1-2 sec after I open the app and I have to kill the application. The browser becomes completely unusable.

6:37 PM, October 06, 2010  
Blogger Yoshinatsu said...

When is WebP support coming?

7:00 PM, October 06, 2010  
Blogger REO said...

Still older Flash plugin used.

10.2.161.23 latest

Win Vista/32 bit

7:15 PM, October 06, 2010  
Blogger molumen said...

10,1,85,3 Flash here...

7:36 PM, October 06, 2010  
Blogger molumen said...

Dbone, I notices that too, the browser seems faster than before!

7:37 PM, October 06, 2010  
Blogger Marasmo said...

The about:labs tab only work on first use. After restart the Chrome (this is soooooo Firefox-like), the tab does not work.

Windows 7 (64 bits)

7:53 PM, October 06, 2010  
Blogger Chris said...

themis:

Same problem here, on ubuntu 64 bit. Completely freezes. Have reverted back to beta so I can access my tabs that I left open!

I'll see if there's a bug reported already, if not

8:22 PM, October 06, 2010  
Blogger Ben said...

Dev doesn't load pages on my Macbook anymore... back to firefox until this is fixed

8:24 PM, October 06, 2010  
Blogger William said...

works great here except a lot of images have black bars going through them. Then once you scroll down and go back to that image it's complete. Happened right after I updated to the newest dev and only in Chrome....

8:32 PM, October 06, 2010  
Blogger sandykoufax said...

when visiting(and move cursor) this site,
http://section.cafe.naver.com/
error occur.
This error appeared when after using 536.2. :(

9:21 PM, October 06, 2010  
Blogger slipstream said...

Known nasty bug that wasn't mentioned in the release summary:

Built-in PDF viewer is unusable, hangs before displaying any pdf content and hangs all the other tabs too. Closing the pdf tab would not help, you'll have to kill/restart Chrome.

(Issue 58040: Renderer crash while trying to load some pdfs)

9:47 PM, October 06, 2010  
Blogger Tyler Sebastian said...

As stated above, Dev is broken on my MacBook...

9:48 PM, October 06, 2010  
Blogger Once Upon A Time said...

Thanks for fixing the design of NTP for "most visited" and "recently closed"

Another question, why only 8 "most visited" window are allowed on the NTP.

People are now using bigger monitor for the desktop computer. There will be a huge blank space if only 8 are allowed.

Is that possible to add an option that users can choose more "most visited" windows on the NTP????

10:17 PM, October 06, 2010  
Blogger JuL said...

Mine won't update to anything more than 7.0.536.2 dev. Has the release been stopped ?

1:03 AM, October 07, 2010  
Blogger EstGun1 said...

to - Once Upon A Time.

I agree completely.

4:33 AM, October 07, 2010  
Blogger Per Bylund said...

I confirm what slipstream wrote about the PDF viewer. I was unable to get the new version of Chrome to work before I killed the open tabs with PDF files and restarted the browser. Had it not been for slipstream I would have had a totally unusable browser...

4:38 AM, October 07, 2010  
Blogger Kay S.T. said...

Please star this and I won't annoy you anymore :-P

http://code.google.com/p/chromium/issues/detail?id=43680

5:52 AM, October 07, 2010  
Anonymous Anonymous said...

The Flash player 10.2.161.23 "Square"
is a beta version of Flash for IE9 beta.I don't think it will be used in Chrome.

6:05 AM, October 07, 2010  
Blogger 大眼夹 said...

I hide the two sections in the NTP, but how can they recover? I don't wanna blank new tab page :(

8:01 AM, October 07, 2010  
Blogger slipstream said...

@大眼夹

Temporarily enable the Bookmarks Bar, then the "recover" buttons would pop up at the bottom-left edge of the New Tab Page.

8:11 AM, October 07, 2010  
Blogger 大眼夹 said...

@slipstream

I see... I need to enable Bookmarks Bar forcibly so that the Chrome logo and the two sections will display in the bottom of new tab page.
Sorry for ignoring previous comments

8:22 AM, October 07, 2010  
Blogger David said...

I have noticed a lot of new bugs in this version (OSX): freezes when I open a PDF, extremely small print size, constant hangs and crashes while surfing. I think I'll stick with FF until the next dev release...

9:00 AM, October 07, 2010  
Blogger Dark Shadow said...

7.0536.2 dev ays in about "restart google chrome to finish updating" - so far ~ 10 restarts .. 3-4 not now, and manually close and than reopen. even tested killing eith task manager all instances

still, the next time i open it says the same ... "restart /Not now"

ideas?

1:34 PM, October 07, 2010  
Blogger David said...

I have also noticed bug (Issue 58040: Renderer crash while trying to load some pdfs). I need to completely killl the Chrome process -- it uses the maximal percentage of CPU on the core that it runs on when I view a PDF.

OS: Windows 7 - 64 bit.


Other than this issue, I haven't seen any other bugs in regular use.

2:11 PM, October 07, 2010  
Blogger Blair "Bobbias" Stacey said...

It appears that this release is somewhat unstable. I've had web pages crash randomly on me for the first time in a very long time (I've been using chrome as my main browser almost since it was announced). The crashes seem completely random, and they began almost right after I switched to 7.0.544.0. I don't want to post in the bug tracker until I've figured out a bit more about these crashes, but I don't really know what to do to get more info on them (about:net-internals is no use).

4:30 PM, October 07, 2010  
Blogger Tato said...

I have a little problem.. When I enable Page Info Bubble it works fine, but then I disable it and still showing the info as a bubble.. Just so you know..

7:37 PM, October 07, 2010  
Blogger Tato said...

The problem solved after four restarts and a few enable/disable.. Don't know why it was the way it ways.. Just saying.. Sorry for the spamming..

7:39 PM, October 07, 2010  
Blogger Andrew said...

I was messing around with enabling a few of the labs features and it totally froze up everything in the browser. I cant even use the dev chrome on mac any more. It hangs as soon as it opens and have to force quit t close. I went back to the beta and everything seems ok. Can you delete your labs enables from outside the browser? That what I believe i borking it out.

8:38 PM, October 07, 2010  
Blogger Noster said...

Hello,

i was trying to download an attachment from hotmail, a word document, but no luck. Does anyone have the same issue?

12:51 AM, October 08, 2010  
Blogger slipstream said...

@Noster

Seems yes: Issue 57334: hotmail.com : Fail to download the attached files

2:16 AM, October 08, 2010  
Blogger Sanat said...

Biolab Disaster stopped working on this build :-(

2:20 AM, October 08, 2010  
Blogger Sanat said...

ok...it works if I knock off the --enable-accelerated-2d-canvas switch

2:22 AM, October 08, 2010  
Blogger JuL said...

@Dark Shadow : Yes, I have exactly the same problem ! I get stuck with 7.0.536.2 dev, no matter how many times I restart...

7:37 AM, October 08, 2010  
Anonymous Anonymous said...

Crashes on PDF's, had to disable PDF plugin.
Lot's of white missing horizontal bands in pictures.

Win7 x64
GeForce Go 7700 driver 257.41

12:05 PM, October 08, 2010  
Blogger - said...

Like some people said above, images aren't working correctly and almost always have black or white bars running across them that can be removed by scrolling the window so the image hides and reappears on the page. Really annoying.

Same actually happened with my captcha image below...

2:18 PM, October 08, 2010  
Blogger Jeff said...

my mouse disappears unless i move it in chrome. waht gives?

6:52 PM, October 08, 2010  
Blogger Dustin said...

Anyone know why I am still getting 2-5 fps in the Fish Tank IE9 demo even though the GPU process is running in about:memory? I have not been able to get true GPU acceleration in Chrome at all. Compositing appears to be running, it's just not accelerating any of the content on the IE9 demo page.

7:59 PM, October 08, 2010  
Blogger Dustin said...

Forgot to add I am running windows 7 pro 64 bit and a radeon 5770 gpu

8:06 PM, October 08, 2010  
Blogger slipstream said...

@William
@jenniferjohnny

Known bug in recent WebKit: Issue 57723: Web Pages with multiple images occasionally show Blank bars that interrupt the image


@Tato

Yep, glitches indeed. Btw, couple days later this Page Info Bubble lab experiment toggle was removed, the "Bubble" mode is now default and the old dialog box code scheduled for deletion.

8:23 PM, October 08, 2010  
Blogger Lockerz Convites said...

This comment has been removed by the author.

10:29 PM, October 08, 2010  
Blogger Random said...

Chrome ALWAYS crash when you spend ten or more seconds choosing a file to upload, can you guys fix it?

10:34 PM, October 08, 2010  
Blogger Tim B. said...

Still stuck on 7.536.2.. Restarting does not update. Keeps telling me to restart, but doesn't upgrade.

6:18 AM, October 09, 2010  
Blogger dario said...

CON ESTA VERSION 7.0.544.0 NO ME FUNCIONA BIEN EL TRACUTOR SIEMPRE ME DA ERROR Y NO PUEDE TRADUCIR LAS PAGINAS

3:55 PM, October 09, 2010  
Blogger molumen said...

'show in folder' link from the download bar doesn't work. It's been happening a few versions version before, lots of people are reporting the same issue. If you got the same issue, please report (or just star the bug) here: http://code.google.com/p/chromium/issues/detail?id=55826

3:54 AM, October 11, 2010  
Blogger Saliman said...

Hi... ever since the last update, pictures and images are loading up with blank parts in them.

This is a fast machine, with a Phenom CPU, 6GB of RAM and atleast 4TB of HDD Space, plus a great GFX card.

This shouldn't be happening.

1:55 PM, October 11, 2010  
Blogger slipstream said...

@Saliman

Known bug for this build, fixed 3 days ago

8:20 PM, October 11, 2010  
Blogger Handycam said...

Not really a bug, but I am wondering why some themes on Mac are translucent at times. For example, I am using "Dawn", and occasionally for no reason I can discern the title bar is translucent, the it become opaque again.

1:55 PM, October 12, 2010  
Blogger Eirik Lygre said...

And me: 7.0.536.2 dev will not update. Says "Restart Google Chrome to finish updating", but no success after many, many updates.

2:53 PM, October 21, 2010  
Blogger Jamie said...

@Dark Shadow
@JuL
@Tim B
Did any of you resolve Chrome Dev not updating on restart? I tried uninstall/reinstall, but it happened again with the next build release.

6:20 AM, October 28, 2010  

Post a Comment

Subscribe to Post Comments [Atom]

<< Home