Wednesday, December 1, 2010

Dev Channel Update

The Dev channel has been updated to 9.0.597.0 for Windows, Mac, Linux, and Chrome Frame

All
  • Ongoing work on IndexDB and GPU
  • Tweaks/Fixes to Google Chrome Instant
  • Extensions/Apps work
  • Autofill related fixes
Known Issues
  • Page becomes unresponsive when trying to play video - Issue 65772
  • Certain HTML5 sites fail to load due to a compositor issue - Issue 64722
More details about additional changes are available in the svn log of all revision.

You can find out about getting on the Dev channel here: http://dev.chromium.org/getting-involved/dev-channel.

If you find new issues, please let us know by filing a bug at http://code.google.com/p/chromium/issues/entry

Anthony Laforge
Google Chrome

Labels:

70 Comments:

Blogger mtygringo said...

Still having the multiple rundll32.exe issues. I was hoping this would be fixed with this release.

3:05 PM, December 01, 2010  
Blogger TheBashar99 said...

@mtygringo
Are the rundll32 problems related to flash like those shown in http://crbug.com/62905 or are they different? Did you file your own bug about this?

3:25 PM, December 01, 2010  
Blogger jzero15 said...

aww was hoping this update included the Chrome Web Store. W/e Running smooth so far

3:28 PM, December 01, 2010  
Blogger Johnny said...

9.0.597.0 crashes both the developer build and my canary build. I can't open either without it crashing and it asking if I want to restart chrome, endlessly.

3:29 PM, December 01, 2010  
Blogger Kevin L. said...

Same here Johnny. Reinstalling fixed my problem. It's tedious obviously, but it worked.

3:44 PM, December 01, 2010  
Blogger Ismael said...

Password sync is no longer offered?

Also, it kept endlessly crashing - canvas 2D GPU acceleration seems to be the problem

3:48 PM, December 01, 2010  
Blogger Sturgelose said...

Umm, I can't go through the HTMLtest... Some problems with chrome maybe?

3:50 PM, December 01, 2010  
Blogger norbijúzer said...

This update crashed continuosly, until I deleted an extension: Google Mail Checker Plus.
But the official gmail checker/notifier has also crashed the browser as I installed it.

4:01 PM, December 01, 2010  
Blogger ShuttleXpC said...

Thank you for fixing the continual loading of the built in flash player. I hadn't reported the issue, but it was very annoying on the previous Dev build when you would exit Chrome and it would keep the call up for the flash player in taskmgr.

4:10 PM, December 01, 2010  
Blogger Brando212 said...

i posted an issue about the continues crashing it's Issue 64989, and the link is http://code.google.com/p/chromium/issues/detail?id=64989

4:28 PM, December 01, 2010  
Blogger Victor Hooi said...

heya,

My copy is crashing quite a bit as well, when I open up certain pages - can't seem to find a pattern in it yet.

Cheers,
Victor

4:51 PM, December 01, 2010  
Blogger Max M said...

My copy was crashing on startup after this update.

Disabling 2D GPU acceleration or the Google Voice extension fixed this for me. It loads with one or the other enabled, but will crash on start if both are enabled.

5:06 PM, December 01, 2010  
Blogger Jonidimo said...

finally now it works! I couldn't enter to incognition mode in the last relase

5:36 PM, December 01, 2010  
Blogger slubman said...

Where is the "click to play" option for plugins ?

5:51 PM, December 01, 2010  
Blogger Marasmo said...

With 2D GPU acceleration enabled, the Twitter web page don't render.

6:13 PM, December 01, 2010  
Blogger REO said...

Looking Good - Win Vista/32 bit

Thanks Google Dev Team! :)

6:18 PM, December 01, 2010  
Blogger Ghardas said...

The Dev chanel keeps going worst on every release. Flash, 2D, HTML5, & other bugs...

And now, with 2D activated, definetly Twitter doesn't render (I've been saying New Twitter doesn't work properly on every release since Chrome 7 Dev!)

6:33 PM, December 01, 2010  
Blogger dasklney said...

Keep crashing when I open Chrome dev, reinstall didn't fix :(

7:00 PM, December 01, 2010  
Blogger Hilmy said...

Completely unusable on Ubuntu 10.04. Crashes even before doing anything. Couldn't even go to disable extensions and flags.

7:01 PM, December 01, 2010  
Blogger elnícopo. said...

fix Twitter please!!

7:03 PM, December 01, 2010  
Blogger Tristan said...

I disabled the gpu acceleration manually by removing a line on the preferences file

7:09 PM, December 01, 2010  
Blogger Bryan Chung said...

This build crashed my Chrome constantly. :(

7:14 PM, December 01, 2010  
Blogger bsee said...

Like a few others, it goes into a constant crash-restart loop. Since it won't load, I can't figure out which extension is causing the problem. So...update soon guys. Soon.

7:47 PM, December 01, 2010  
Blogger Renan said...

Same problem here chrome keep crashing and asking to restart and it keep going in a endless loop =(

7:51 PM, December 01, 2010  
Blogger Webspiders said...

Thanks for sharing the update.
pisocialmedia

7:54 PM, December 01, 2010  
Blogger Charles G. said...

If you have the Gmail checker extension and GPU Hardware Acceleration enabled in the about:flags, then it will crash. I disabled the acceleration cause I need my extensions.

8:53 PM, December 01, 2010  
Blogger Sara said...

With 2D GPU acceleration enabled, the Twitter web page don't rende

9:39 PM, December 01, 2010  
Blogger Junsung said...

This comment has been removed by the author.

9:58 PM, December 01, 2010  
Blogger Junsung said...

this update is terrible.

I never use the chrome browser.

Whenever I contact by chrome on the INTERNET, I can't enter on it.

how does it use chrome?

I hate the Internet Explorer8
So, please solve the terrible problem...

9:59 PM, December 01, 2010  
Blogger Thesandlord said...

Same problem here, crashes right after it opens. Can't change any of the settings because it crashes too fast.

10:33 PM, December 01, 2010  
Blogger Brendan said...

Mibbit page won't render in this new update, rendered in previous version
Hardware Acceleration Enabled

10:45 PM, December 01, 2010  
Blogger Rick P. said...

The quickest way to resolve the problem is right click the icon and open incognito. Type about:flags in the address bar to disable GPU Accelerated Canvas 2D. Gotta love living on the bleeding edge.

10:49 PM, December 01, 2010  
Blogger Brendan said...

Interestingly enough, it doesn't work either way, so I guess hardware acceleration isn't the problem?

10:55 PM, December 01, 2010  
Blogger Junsung said...

This comment has been removed by the author.

11:02 PM, December 01, 2010  
Blogger Junsung said...

I didn't open incognito mode, neither.

Ah, from right before I use the Opera browser.
I'm not satisfied with the one.
I hope that chrome browser go normally back early.

11:02 PM, December 01, 2010  
Blogger David Knowles said...

Lots of problems.

But when this version of chrome does work it is fast at rendering page.
But this is the first time I actually felt like I have been using a developer version.

11:18 PM, December 01, 2010  
Blogger Pece said...

--disable-accelerated-compositing fixes the crashes for me

12:32 AM, December 02, 2010  
Blogger gharou said...

That bug with too narrow extension drop-down still occurs. It's really annoying.

12:39 AM, December 02, 2010  
Anonymous Anonymous said...

I was hoping this would be fixed with this release:
http://db.tt/xmVflTY

1:00 AM, December 02, 2010  
Blogger Apicio said...

I disabled "gpu 2d accelerated canvas" or something like this in "Preferences" file and now it does not crash, btw, I think devteam should revert this rel or release a fix quicky!

1:18 AM, December 02, 2010  
Anonymous Anonymous said...

inkognito mode takes cookies from recently opened sites!

1:47 AM, December 02, 2010  
Blogger neoGeneva said...

@Pece --disable-accelerated-compositing fixed it for me also, thanks!

2:00 AM, December 02, 2010  
Blogger Renan said...

How do I disable GPU Hardware Acceleration if chrome crashs every time I start it ??

3:29 AM, December 02, 2010  
Blogger Luuk said...

@Renan, add --disable-accelerated-compositing to the command target by editing the shortcut properties

3:50 AM, December 02, 2010  
Blogger The Right Miller said...

Reinstalled the dev channel version of Chrome last night after repeated crashes upon startup. Worked fine at that time. Tried to use Chrome this morning and the repeated crashes upon startup had returned. Opened in incognito mode and disabled 2D hardware acceleration. Restarted and now cannot open in either mode without crashing. Next steps, please?

3:52 AM, December 02, 2010  
Blogger Cakalaky said...

I cannot open Chrome without it crashing. I am able to open Chrome in incognito mode without any issues. So with incognito mode window open, I am able to open Chrome in normal mode without any issues. Win 7 Pro 64Bit.

5:26 AM, December 02, 2010  
Blogger Keith said...

Crashes repeatedly on Windows 7 x64 if --enable-aero-peek-tabs switch enabled.

6:47 AM, December 02, 2010  
Blogger kamochan said...

I recovered this situation, you will try "--no-experiments" start option.

6:54 AM, December 02, 2010  
Anonymous Anonymous said...

Crash only happens for me if I have the google voice plug in loaded

6:57 AM, December 02, 2010  
Blogger Thanh said...

I love how long they are taking to fix something that worked perfectly fine before (narrow extension drop-down menus)... oh wait, no I am not T_T

7:25 AM, December 02, 2010  
Blogger Marasmo said...

Reporting a crash:
- Access this site: http://forcomp.blogspot.com/search?updated-max=2009-03-24T08:15:00-03:00&max-results=100 Work well
- Change the max-result parameter for 200. Crash!

7:29 AM, December 02, 2010  
Blogger Ahmad Saleem said...

Download this version:
http://dl.google.com/chrome/install/597.2/chrome_installer.exe

Check this version, wither you guys get crashes or not.

8:10 AM, December 02, 2010  
Blogger Kryptyx said...

Seems like certain websites don't render still even in 9.0.597.2, however in the 597.2 release accelerated 2D canvas can be checked and no longer crashes. Certain websites still don't render though.

mmo-champion.com for example.

8:24 AM, December 02, 2010  
Blogger Βασίλης said...

With this extention you can access about:flags page easily.I disabled Accelerated Canvas 2D and worked fine for me. http://goo.gl/SDtN

11:06 AM, December 02, 2010  
Anonymous Anonymous said...

Sound in flash videos doesn't work.
Sorry for my poor english.

2:55 PM, December 02, 2010  
Blogger Renan said...

@Luuk thanks it worked !! =)

3:22 PM, December 02, 2010  
Blogger sam said...

On the mac: native client is enabled in about:flags, but it doesn't actually work unless I enter the flag in manually on the command line.

4:03 PM, December 02, 2010  
Blogger HurpDurp said...

Just thought I'd let you know the GPU crash was effecting me too until I manually removed it from the preference file.

5:01 PM, December 02, 2010  
Blogger Melissa said...

I have two older man willing to come to your house and get it ready for christmas.for when your kids come home for Christmas.Thet do contrating they are Ocean Certify.You tired of doing this work year after year!Let some one else do it for you.Please Call At213-6669 or 547-0199 Make your job easy please call ask for melissa or scott.

4:51 AM, December 03, 2010  
Blogger Рапитура said...

Guys great issue appears - Chrome crashes after start.

10:11 AM, December 03, 2010  
Blogger Avinash Agrawal said...

Consistent crash on windows 7 at startup. Previous dev version was working fine.

10:49 PM, December 03, 2010  
Blogger Avinash Agrawal said...

In gmail, on windows xp, clicking "Contacts" hangs up computer; previous dev version worked fine. Also some gmail extensions are not working correctly.

10:50 PM, December 03, 2010  
Blogger bt said...

Seems to be a bug that crashes a page with flash video such as any youtube video from time to time.

The page will become unresponsive and checking the task manager, it'll say that that page is using up about 60% CPU and it'll get the fan spinning.

Running flash player "Square" version 10.3.

9:54 AM, December 04, 2010  
Blogger Avinash Agrawal said...

Seems joining the html5 experiment http://www.youtube.com/html5 , and watching any you youtube video in html5 hangs the browser (latest dev).

Also clicking on google voice extension is not opening the small pop-up window (latest dev).

And lots of brwowser hangs in general, with this version, esp in gmail.

8:37 PM, December 04, 2010  
Blogger H.F.Kais said...

fix file upload!!! plz!!!

8:56 AM, December 05, 2010  
Blogger Juuso said...

By far the most unstable version of Chrome I've ever used and I've been a user since the beginning.

80% of the times loading a web page ends up in some sort of a crash or error. I'm running this on Win 7 Ultimate x64

12:14 PM, December 05, 2010  
Blogger Kent_Geek said...

My 9.0.587.0 keeps trying to update to 597, but fails every time (with no error messages seen). I appear to be stuck.

7:23 AM, December 06, 2010  
Blogger Kent Geek said...

My 9.0.587.0 keeps trying to update to 597, but fails every time (with no error messages seen). I appear to be stuck.

7:25 AM, December 06, 2010  
Blogger danijel2006 said...

BUG with upload element... you need to select file twice...

10:17 AM, December 06, 2010  
Blogger dbone said...

worst release in a while. lots of freezes

5:15 PM, December 06, 2010  

Post a Comment

Subscribe to Post Comments [Atom]

<< Home