Wednesday, April 18, 2012

Beta Channel Update

The Beta channel has been updated to 19.0.1084.30 for Windows, Mac, Linux, and Chrome Frame. 

Take a look at the changelog to see what happened in this release, we've update the localization and fixed a number of stability issues.

If you'd like to get on the Beta channel, you can download it from our Beta download page. If you find a new issue, please let us know by filing a bug.

Anthony Laforge
Google Chrome

Labels:

8 Comments:

Blogger Sammy Guergachi said...

Flash is acting weird, videos on youtube start without audio then a second later video pauses to catch up to audio. pausing causes video to stop but audio to keep
playing for a couple secs

7:48 PM, April 18, 2012  
Blogger Hemant said...

Flash keeps crashing and pages are becoming unresponsive all the time taking a long time to open.

7:56 PM, April 18, 2012  
Blogger Zsolt Tam├ís Gfellner said...

Flash Player is still not updated?

still ver_11,2,202,229 -

whats going on with these flash issues chrome team?

12:27 AM, April 19, 2012  
Blogger Sander Sturing said...

Flash sucks anyway, I hope it will never get fixed in Chrome so everybody is forced to abandon Flash :D
Oh, the thought... UTOPIA!

1:46 AM, April 19, 2012  
Blogger Alex von Fersen said...

Join the HTML5 trial on youtube instead. F*ck flash!
http://www.youtube.com/html5

3:45 AM, April 19, 2012  
Anonymous Anonymous said...

The last two comments... Really.

Have you forgotten that Google said it'll remove support for H.264? Guess what, you're stuck with Flash!

Or, by the looks of it, maybe Google wants us to forget it ever said that.

6:38 AM, April 19, 2012  
Blogger the don said...

Flash or not too Flash that is the Question????,get it sorted Chrome.

11:00 AM, April 19, 2012  
Blogger Johnathon said...

Flash is just as "weird" as always i.e. no better or worse.

From Adobe's info - the flash update is not security and there only fix is Windows printing. I'm surprised Google doesn't want to bundle it, but one can always manually switch using about:plugins to the latest 11.2.202.233 !

2:31 AM, April 20, 2012  

Post a Comment

Subscribe to Post Comments [Atom]

<< Home