Thursday, October 3, 2013

Stable Channel Update

The Stable Channel has been updated to 30.0.1599.69 for Windows, Mac and Chrome Frame.

This update fixes the top two user issues with the latest stable build:

  • Tabs freeze up (Issue: 303293)
  • Lag in some games/GPU issues with certain monitors (Issue: 262437)

Interested in switching release channels? Find out how. If you find a new issue, please let us know by filing a bug.

Karen Grunberg
Google Chrome

Labels:

10 Comments:

Blogger Hossam Khelili said...

link to download
http://dl.google.com/chrome/win/D62E8163A4A60332/30.0.1599.69_chrome_installer.exe

5:21 PM, October 03, 2013  
Blogger Rafael Hilário said...

Thank you Google Chrome team finally solved the problem of the first final version of Google Chrome 31 where all the guides and fought froze the websites on a massive slowdowns and crashing all the time. Thanks for the great work keep it up.

6:42 PM, October 03, 2013  
Blogger SerapH~~ said...

cpu higher than 29

7:05 PM, October 03, 2013  
Blogger Loi said...

Ever since the new update for stable channel,2/3 of videos i watched on youtube are now html5 i don't know why but it's getting incredibly annoying and i can't even disable it.

7:54 AM, October 04, 2013  
Blogger Rafael Hilário said...

I would suggest Team Google Chrome browser in a remodeled changing the layout remains the same and has changed little since their first versions are in need of a new more modern look and hit the front with the other browsers.

8:53 AM, October 04, 2013  
Blogger Александр Чухлебов said...

Loi clear youtube or google cookies

4:08 AM, October 05, 2013  
Blogger Tâm Trần said...

where is my recently bookmarks? :((

6:01 AM, October 05, 2013  
Blogger Fremip said...

This comment has been removed by the author.

3:55 AM, October 06, 2013  
Blogger slim142 said...

I havent been able to access Hotmail.com for the past 7 days.

Can you guys please fix this? It works fine with IE and Firefox.

12:21 PM, October 09, 2013  
Blogger Samurai said...

I have a problem with this update. Chrome 30.0.1599.69

I can't add images from another site.
I think it is the same error discribed here:
https://code.google.com/p/chromium/issues/detail?id=303046

It has to do with NTLM and images from another intranet (sharepoint/iis/ntlm) site giving 401 on my intranet.
Thank you!

10:52 AM, October 14, 2013  

Post a Comment

Subscribe to Post Comments [Atom]

<< Home